sage-300-erp-accounting-software
Effective January 2016 Sage will exclusively support Payroll version 7.2. Support for previous versions will be discontinued, and tax updates for these versions no longer released.
Q: Which versions of payroll will no longer be supported?
A: Support for Payroll 6.0, Payroll 7.0, and Payroll 7.1 and any previous versions will cease in January 2016.
Q: Does this apply to both, the US and Canadian Payroll?
A: Yes, it applies to both
Q: Will Sage continue to provide tax updates for previous versions of payroll?
A: Effective January 2016, Sage will only provide tax updates for Payroll version 7.2.
Q: Which versions of Sage 300 are compatible with Payroll version 7.2?
A: Sage Payroll 7.2 is compatible with Sage 300 versions 2012, 2014, and 2016 (when released in the fall).
Q: Is Payroll 7.2 going to be “backwards compatible” with older versions of the Sage 300’s system manager?
A: Yes, Payroll 7.2 will be backwards compatible with System Manager 2012, 2014, and 2016 (when released in the fall).
Q: What does this mean for customers currently using Payroll version 6.0?
A: Customers on Payroll 6.0 will need to upgrade their entire system and all modules to be compatible with Sage Payroll 7.2.
Q: When is the last tax update for Sage Payroll 6.0 going to be released?
A: The last update for Sage Payroll 6.0 will be released in July 2015 for Canadian Payroll, and in September 2015 for US Payroll.
Q: What does this mean for customers on Sage Payroll 7.0 and 7.1?
A: Customers on Sage Payroll versions 7.0 and 7.1 simply need to upgrade their payroll module.
Q: When is the last tax update for Sage Payroll 7.0 and Sage Payroll 7.1 going to be released?
A: The last update for Sage Payroll 7.0 and Sage Payroll 7.1 will be in September 2015.
 
Last tax update available:        
Sage Payroll 6.0 | September 2015
Action Required: Upgrade to Sage 300 or higher and Sage Payroll 7.2 before the end of 2015
Sage Payroll 7.0 | September 2015
Action Required: Upgrade to Sage Payroll 7.2 before the end of 2015
Sage Payroll 7.1| September 2015
Action Required: Upgrade to Sage Payroll 7.2 before the end of 2015
Content Provided by Sage